Using the Interface

The SAS System for UNIX environments features an X Window System interface that is based on Motif. This interface uses the window manager on your system to manage the windows on your display. Window managers govern the placement, sizing, stacking, and appearance of windows, as well as their interaction with the keyboard. A common window manager is the Common Desktop Environment (CDE). All window managers perform the same basic functions, but they differ in their style and in their advanced functions. The appearance of the SAS interface depends partially on which window manager you use.

The basics of interacting with the SAS System are the same for all window managers: opening pull-down and pop-up menus, moving windows, responding to dialog boxes, dragging text, and so on. This chapter describes some of the dialog boxes and features specific to SAS.

Many features of the SAS graphical interface are controlled by X resources. For example, colors, window sizes, the appearance of the toolbox, and key definitions are all controlled through resources. The following sections might refer to a specific resource that controls a feature of the interface. “Customizing Your Windowing Environment” on
Using Function Keys

Function keys provide quick access to commands. They allow you to issue commands, insert text strings, and insert commands in programs. Function key definitions may be different on different terminals. To display your function key definitions, open the KEYS (DMKEYS) window by pressing F2, by issuing the KEYS command, or by selecting Tools ▶ Options ▶ Keys.

Display 2.1  KEYS (DMKEYS) Window

To view a single key definition without bringing up the KEYS window, use the KEYDEF command and specify the key definition that you want to view. For example, the following command displays the definition for key F4:

keydef f4

For information on customizing key definitions, see “Customizing Key Definitions” on page 54. Refer to SAS Language Reference: Dictionary for more information on the KEYS window and the KEYDEF command.
Selecting (Marking) Text

When you select text in a SAS window, you can select character strings or blocks. Character strings include the text in successive columns of one or more rows, as shown in Display 2.2 on page 23. Blocks are rectangular blocks that include the same columns from successive rows, as shown in Display 2.3 on page 23.

Display 2.2  Strings That Are Marked

You can select text in three different ways:

- Position the cursor at the beginning of the text that you want to mark and press and hold the left mouse button. Drag the mouse pointer over the text that you want to mark, and press and hold down the Alt key (or Extend char key or Meta key, depending on your keyboard) while you release the mouse button. The marks that are generated by the mouse are called drag marks. If you want to select a block instead of a string, press and hold the CTRL key before you press the left mouse button. To extend an area of marked text, press and hold the Shift key, and use the left mouse button and the Alt key (and the CTRL key, if you are marking a
block) to mark the new ending position. To unmark the selected text, press the mouse button anywhere in the window.

- Use the MARK command as described in the online help. Position the cursor at the beginning of the text that you want to mark and issue the MARK command. Then, move the cursor to the end of the text that you want to mark, and issue the MARK command a second time. You can issue the MARK command from the command line, or you can assign it to a function key. If you want to select a block instead of a string, add the BLOCK argument to the MARK command. With the MARK command, you can select more than one area of text in the same window at the same time. To unmark the selected text, issue the UNMARK command.

- Position the cursor at the beginning of the text that you want to mark and select

  ![Edit ➤ Select](image)

  Position the cursor to the end of the text that you want to mark and press the left mouse button. To unmark the selected text, select

  ![Edit ➤ Deselect](image)

  **Note:** The text that you select might not remain highlighted although it has been copied into the paste buffer.

---

### Copying or Cutting and Pasting Selected Text

After you have marked text, you can copy or cut the text and paste it in another location. To copy text, select the Copy toolbox icon, issue the STORE or WCOPY command, or select

![Edit ➤ Copy](image)

To cut text, select the Cut toolbox icon, issue the CUT or WCUT command, or select

![Edit ➤ Cut](image)

To paste the cut or copied text, select the Paste toolbox icon, issue the PASTE or WPASTE command, or select

![Edit ➤ Paste](image)

For more information on the CUT, PASTE, and STORE commands, refer to SAS Language Reference Dictionary.

When you end a drag mark by releasing the mouse button without holding down the Alt key, the SAS System performs an end-of-mark action that might automatically generate a STORE command to save the contents of the mark into a SAS paste buffer. If the STORE command is generated automatically, you do not have to explicitly copy the text before you paste it. If you do not want SAS to automatically store the text, set the `SAS.markPasteBuffer` resource to disable automatic paste buffer storage. You can also disable the automatic paste buffer storage by deselecting **Automatically store selection** on the Editing tab in the Preferences dialog box:

![Tools ➤ Options ➤ Preferences...](image)

For more information, see “Customizing Cut-and-Paste” on page 72.
Copying and Pasting Text between SAS and Other X Clients

You can cut or copy and paste text between X clients if you associate the default SAS paste buffer with a paste buffer specific to X. For example, if you associate the default SAS paste buffer with the XTERM paste buffer, you can copy and paste text between xterm windows and SAS windows. To associate the SAS buffer with an X buffer, specify the `SAS.defaultPasteBuffer` resource. For example:

```
SAS.defaultPasteBuffer: XTERM
```

For more information about using paste buffers, see “Customizing Cut-and-Paste” on page 72.

Using the Graphics Clipboard

In the Image Editor, GRAPH window, and Graphics Editor window, you can copy items to the Clipboard by selecting `Edit` ► `Copy`

SAS creates an SPM-format file with the name `/tmp/SASgstore_pid.spm`. pid is the process ID number.

You can paste items from the Clipboard by selecting `Edit` ► `Paste`

SAS attempts to read an SPM-format file with the name `/tmp/SASgstore_pid.spm`.

- The `graphicsClipboardPath` resource specifies the location of the clipboard file. The default location is `/usr/tmp`.
- The default clipboard format is SPM (SAS Pixmap). This format is a proprietary format and is architecture-dependent.
- The clipboard file is permanent between sessions for each user.

Using Drag and Drop

The SAS windowing environment on UNIX offers two types of drag and drop: default and nondefault. Default drag and drop allows you to move text from one place to another. Nondefault drag and drop allows you to choose whether to move or copy the text, submit the text if you are dragging SAS code, or cancel the drag and drop operation. With default drag and drop, you can drag text between SAS windows in different SAS sessions and between SAS windows and other Motif applications, such as Mosaic, that support drag and drop. Nondefault drag and drop is available only between windows in the same SAS session.

Under UNIX, you cannot drag and drop files or RTF (Rich Text Format) text.

To drag and drop text, first mark the text in one of the ways described in “Selecting (Marking) Text” on page 23. To use default drag and drop, simply use MB2 to drag the text where you want it. To use nondefault drag and drop, press and hold the Alt (or Extend Char) key before you release MB2.
Using the Command Window and the Toolbox

You can use the command window to enter commands in the active SAS window. The name of the active window is displayed in the title bar of the command window. Toolboxes allow you to associate icons with commands. You can define multiple toolboxes and switch between them, and you can define toolboxes for specific windows or applications, such as SAS/AF applications. By default, the toolbox and the command window are joined and are automatically displayed when the SAS System initializes unless

- you executed your SAS job in a nonwindowing environment mode.
- the SAS.defaultToolBox or SAS.defaultCommandWindow resource is set to False. The default value is True. For more information about the resources that control the toolbox, see “Specifying Toolbox Resources” on page 49.
- you deselect Display tools window, Display command window, or Combine windows from the Toolbox tab in the Preferences dialog box.

Display 2.4 on page 26 shows the command window and the toolbox in their default configuration.

Display 2.4 Command Window and Default Toolbox

When the command window and the toolbox are joined, you can open both of them by doing any of the following:

- issuing the COMMAND WINDOW command
- selecting Tools ► Options ► Toolbox
- issuing the TOOLLOAD command. See “TOOLLOAD” on page 186 for more information.

You can close both of them by doing any of the following:

- double-clicking on the window menu button for the combined command window and toolbox.
- selecting close from the toolbox window menu.
- entering the TOOLCLOSE command as described in “TOOLCLOSE” on page 184.
- deselecting Tools ► Options ► Toolbox again so that Toolbox is deselected.

Using the Command Window

You can open only the command window by deselecting Combine windows from the Toolbox tab in the Preferences dialog box and doing any of the following:

- selecting Display command window in the Preferences dialog box
- issuing the COMMAND WINDOW command.
To execute a command, click in the command window, type in the command, and press Enter or select the check mark. The command is executed in the active SAS window. You can use the up and down arrow keys to scroll through previously entered commands, or you can select a previous command from the drop-down list. Use the left mouse button to select a command from the drop-down list. Use MB2 to select and execute a command from the list.

You can close the command window by selecting Close from the window menu or double-clicking on the window menu button. You can close only the command window by deselecting Display command window in the Preferences dialog box.

---

### Using Toolboxes

Clicking on a tool icon in a toolbox executes the command or commands associated with that icon. If you place the cursor over an icon for the amount of time specified by the SAS.toolBoxTipDelay resource, a pop-up displays text that describes the command for that icon.

You can open only the toolbox by deselecting Combine windows from the Toolbox tab in the Preferences dialog box and doing any of the following:

- selecting Display tools window in the Preferences dialog box
- selecting Tools ▶ Options ▶ Toolbox

again so that Toolbox is deselected.

- issuing the TOOLLOAD command. See “TOOLLOAD” on page 186 for more information.

The default toolbox is automatically copied to your SASUSER.PROFILE.DMS.TOOLBOX regardless of whether you customize the toolbox. If you invoke an application that does not have an associated PMENU entry, the default toolbox is displayed for that application. If you then customize the toolbox for that application, the customized toolbox is stored in SASUSER.PROFILE.DEFAULT.TOOLBOX.

You can customize the default toolbox, create multiple toolboxes and switch between them, and create application-specific toolboxes that are automatically loaded when the application is loaded. Only one toolbox is displayed at a time, and the tools in the toolbox change as you move between applications.

You can close only the toolbox by deselecting Combine windows from the Toolbox tab in the Preferences dialog box and doing any of the following:

- deselecting Display tools window in the Preferences dialog box
- issuing the TOOLCLOSE command as described in “TOOLCLOSE” on page 184.
- deselecting Tools ▶ Options ▶ Toolbox

again so that Toolbox is deselected.

For information on customizing a toolbox, see “Using the Tool Editor” on page 50. For information on application-specific toolboxes, see “Creating or Customizing an Application- or Window-Specific Toolbox” on page 54. For descriptions of the SAS resources that control toolbox behavior, see “Specifying Toolbox Resources” on page 49.
Opening Files

The Open dialog box enables you to select files from the host file system. To open this dialog box, select:

File ▶ Open...

**Display 2.5** Open Dialog Box

The Open dialog box contains two list boxes:

**Directories**

contains the names of the directories specified in the Filter field.

**Files**

contains the files in the selected directory that match the filter specified.

The dialog box displays nonreadable directories with a different icon. To display a list of all the files in a directory, enter the asterisk (*) wild card in the Filter field or select All Files; * as the file type.

The directory shown under the Filter field is the currently selected directory. You can change this directory either by selecting a name from the Directories list or by typing the new name directly into the field.

To include or exclude hidden files and directories from the graphical display, select or deselect Include hidden.

To specify that both upper- and lowercase names be included in the display, select Ignore Case. (If you select All Files; * as the filter, both upper- and lowercase names are displayed whether or not you select Ignore Case.)

You can specify the initial filter in the File type field by assigning a value to the SAS.pattern resource. However, the Open dialog box retains its filter between invocations, so the SAS.pattern resource applies only to the first invocation of the Open dialog box. You can also use the SAS.directory resource to specify the directory that you want when you first invoke the Open dialog box.
For more information about specifying SAS resources, see “Using X Resources to Customize the Motif Interface” on page 38.

---

**Using Regular Expressions in Filenames**

Everything that you enter into the Open dialog box is treated as a regular expression. When you are opening or saving a file and you want to use a regular expression special character as part of the filename, precede the character with a backslash (\). For example, to write to a file named $jan, enter \$jan as the filename.

For more information on regular expressions, refer to man page 5 for regexp:

```bash
man 5 regexp
```

---

**Changing Your Working Directory**

The working directory is the operating system directory to which many SAS commands and actions apply. By default, the SAS System uses the current directory as the working directory when you begin your SAS session.

You can change the working directory during your SAS session. You can use the Change Working Directory dialog box to select a new directory, or you can use the X command, the X statement, the CALL SYSTEM routine, or the %SYSEXEC macro statement to issue the change directory (cd) command. For information on the X command and statement, the CALL SYSTEM routine, and the %SYSEXEC macro statement, see “Executing Operating System Commands from Your SAS Session” on page 12.

To open the Change Working Directory dialog box, issue the DLGCDIR command or select

```
Tools  ➤  Options  ➤  Change Directory...
```
Searching For and Replacing Text Strings

The Find and Replace dialog boxes (Display 2.7 on page 31) allow you to search for and replace strings in SAS text editor windows such as the Program Editor, the SCL editor, or the Notepad. To search for a string, open the Find dialog box by issuing the DLGFIND command or by selecting

\[\text{Edit} \rightarrow \text{Find...}\]

To replace one text string with another, open the Replace dialog box by issuing the DLGREPLACE command or by selecting

\[\text{Edit} \rightarrow \text{Replace...}\]

The Find dialog box works like the Replace dialog box, except it does not have the Replace field or the [Replace] and [Replace All] buttons.
Display 2.7  Replace Dialog Box

To find a character string, type the string in the Find field, and select [Find]. To change a character string, type the string in the Find field, type its replacement in the Replace field, and select [Replace]. To change every occurrence of the string to its replacement string, select [Replace All].

You can tailor your find or replace operation using the following buttons:

**Match Case**
- tells the search to match the uppercase and lowercase characters exactly as you entered them.

**Match Word**
- searches for the specified string delimited by space, end-of-line, or end-of-file characters.

**Previous**
- searches from the current cursor position toward the beginning of the file.

**Next**
- searches from the current cursor position toward the end of the file.

---

**Sending Mail from within Your SAS Session**

The Send Mail dialog box (Display 2.8 on page 32) allows you to send e-mail without leaving your current SAS session.
Display 2.8  Send Mail Dialog Box

The dialog box automatically grabs the contents of the active SAS text window, so you can include the window contents in your message quickly and easily. If you do not want to include the contents of the active SAS editor window in your message, select before invoking the Send Mail dialog box.

To invoke the dialog box, select

To send e-mail, enter the ID(s) of the e-mail recipients in the To and Cc fields, edit the entry in the Subject line as needed, and select Send. Separate multiple addresses with either blanks or commas. To cancel a message, select Cancel.

You can use the EMAILSYS system option to specify which script you want to use for sending electronic mail. See “EMAILSYS” on page 266 for more information.

Previewing Output

If you have host printing turned on, you can preview your output before you send it to a printer, plotter, or external file. For information on defining printers and turning on host printing, see “Setting Up Host Printing” on page 145.

Previewing Your Output

After you generate output to your Output window, issue the DLGPRTPREVIEW command or select

File ➤ Print preview...
SAS opens the Print Preview window, which contains a snapshot of the contents of the active window.

If your output contains multiple pages, you can
- page through the output by selecting the arrows on either side of the Page field
- enter a specific page number in the Page field
- select Show two pages to see two pages at once.

To change the size of the preview output, select 33%, 66%, or 100% from the Zoom selection list.
- Print... opens the appropriate Print dialog box, dependent on whether you are printing from a text window or printing from a graphics window. This button does not appear when the Print Preview dialog box is invoked from certain applications.
- Export... opens the Export dialog box, which allows you to export the current preview view to any image format supported by SAS/GRAPH with Image extensions. Select the file or type the filename to which you want to save the view, select the file format needed, and select OK.

Note. The display fonts used in the Print Preview window may not match the fonts used when the window is printed. The Print Preview window uses the display font that most closely matches the font that will be used to print the window contents.

---

**Previewing Output from within SAS/AF Applications**

To preview output from within a SAS/AF application, use the DLGPRTMODE and DLGPRTPREVIEW commands to turn on preview mode, print the output, open the Print Preview dialog box, and then turn preview mode off. For example, the following code prints the GRAPH1 object using the host drivers and displays it in the Preview dialog box:

```sas
/* Turn on preview mode. */
CALL EXECMDI ("DLGPRTMODE PREVIEW");
/* Print the graph */
GRAPH1._PRINT_();
/* Open the Preview dialog box */
CALL EXECMDI ("DLGPRTPREVIEW");
/* Turn off preview mode */
CALL EXECMDI ("DLGPRTMODE HOST");
```

---

**Printing from the SAS System**

You can print text from within your SAS session by using host printing or forms. You can print graphics using native SAS/GRAPH drivers or host printing drivers. For information on defining host printers and forms, see “Printing from the SAS System” on page 145. For information on using host printers and forms after they have been set up, see “Producing Output with SAS Software” on page 129. For information on using native SAS/GRAPH drivers, refer to the online help for SAS/GRAPH.

---

**Using the SAS Session Manager (motifxsassm)**

The SAS Session Manager for X (motifxsassm) is an X client that is run by SAS when you use the SAS windowing environment. The session manager window is
automatically minimized (iconified). If you use the window menu to restore it, the session manager appears as shown in Display 2.9 on page 34.

Display 2.9  SAS Session Manager Dialog Box

The session manager window describes which SAS session it controls, the host machine from which the SAS session was invoked, and the UNIX process identifier of the SAS session.

The session manager allows you to

- map and iconize all windows of the SAS session. The Restore and Minimize buttons restore and minimize all of the windows that are open in the SAS session that is controlled by that session manager. These functions are performed with standard X library calls and will work with most X window managers.
- interrupt the SAS session. The Interrupt button sends a UNIX signal to the SAS System. When SAS receives the signal, it displays a dialog box that asks for confirmation before it cancels the submitted statements.
- terminate the SAS session. The Terminate displays a dialog box that asks you to confirm that you want to terminate the SAS session. If you select OK, the session manager sends a UNIX signal to the SAS session that forces the session to terminate.
- use your host editor from within your SAS session. When you issue the HOSTEDIT command, SAS passes the request to the session manager, which then invokes your host editor, so the session manager must be running in order for the HOSTEDIT command to take effect. When you issue the HOSTEDIT command, SAS creates a temporary file that contains the data from the active SAS window and passes this file to your host editor. (These temporary files are stored in the directory specified by the SASWORK option.) When you save your file in the host editor, the file is copied back into the SAS window if the window is writable, and the temporary files are deleted when the SAS session ends. See “Configuring the SAS System for Host Editor Support” on page 78 for more information.

Getting Help

You can access help through one of several methods. To access the main SAS help menu, issue the help command, select the Help icon in the toolbox, or select

Help ➤ SAS System Help

To display help on the active window, select the Help button in the window, or select

Help ➤ Using This Window

To display the SAS CD-ROM documentation, select

Help ➤ Books and Training ➤ SAS OnlineDoc