Assessing Your Spatial Data Needs

You use a geographic information system when you want to explore data in the context of a map, so you must have a map in order to use SAS/GIS software. Further, the map must be in the form of spatial data that SAS/GIS software can use.

Assessing Your Attribute Data

The first step in deciding what spatial data you need is to assess the attribute data that you want to analyze. Obviously, the attribute data must have a spatial component. That is, it must contain at least one variable with values that relate to location. Examples include city, state, or country names or codes; street names; addresses; and so forth. Since SAS/GIS software is part of the SAS System, the attribute data must also be in the form of a SAS data set or SAS view. You can use any method available for transforming your attribute data into a SAS data set or SAS view, if it is not already stored in one of those formats. These methods include, but are not limited to:

- Using SAS DATA steps or the SAS Import Wizard for reading external files into SAS data sets
- Using SAS/ACCESS software or the SQL procedure for creating views to database files
- Using SAS DATA steps or the SQL procedure to create dynamic views to SAS data sets.
Determining Your Spatial Data Requirements

In order to analyze the attribute data with SAS/GIS software, you need spatial data that contain representations of features to at least the same level of detail as the location information in your attribute data. For example, if your attribute data consist of demographic data for states, then your spatial data must provide at least state boundaries. If your attribute data consist of demographic data for smaller census tracts, then you need spatial data containing the corresponding census tract boundaries in order to explore the demographic data with SAS/GIS software.

Locating a Source of Spatial Data

You may be able to purchase appropriate spatial data that have already been prepared in SAS/GIS format by a commercial data vendor. Contact SAS Institute for information on sources for spatial data in SAS/GIS format.

The other way to acquire spatial data for use with SAS/GIS software is to import it from other formats. One readily accessible source of maps for importing is the map data sets provided with SAS/GRAPH software, although these maps provide only political boundaries and not other physical features such as rivers or major highways. Other sources for spatial data that you can import include

- governmental agencies. For example, SAS/GIS software can import spatial data from TIGER files produced by the U.S. Census Bureau and from DLG files produced by the U.S. Geological Survey.
- drawing and computer-aided design (CAD) packages. SAS/GIS software can import the DXF interchange format supported by products from various vendors.
- Dynmap files from Geographic Data Technology, Inc. (GDT).
- MapInfo .MID and .MIF files.
- user-created files. If no other source is available, you can use SAS DATA steps to process your spatial data into the required generic format, which SAS/GIS software can then import.

Whatever the source, the spatial data must have at least one variable with values that match values in the attribute data you want to analyze. If necessary, you can use the SAS System to process either the attribute data or the spatial data. For example, if your attribute data contain state names and your spatial data contain state codes, you can use SAS DATA steps to generate corresponding codes for the names. Likewise, if your attribute data and spatial data both have variables that contain codes to identify areas in the map, but the two sets of data use different codes for the same areas, then you can use SAS DATA steps to translate the coding schemes.

Importing Spatial Data

Suppose you are given the task of determining average household income by county for the states of North Carolina and South Carolina, based on the information collected in the MAPS.USAAC sample attribute data set that is provided with SAS/GIS software. For each U.S. county, this data set has an observation that includes the following variables:

- **STATE**
  - is the FIPS code for the state.
COUNTY

is the FIPS code for the county.

AHI89

is a 1989 estimate of average household income.

In order to analyze the data in MAPS.USAAC, you need a map with corresponding state and county boundaries and compatible identifier values. The MAPS.COUNTIES map data set supplied with SAS/GRAPH software has coordinates for U.S. state and county boundaries and also uses FIPS codes to identify states and counties, so it is a compatible source of spatial data.

To extract map data that contain only the required states, submit the following in the Program Editor window:

```
data work.ncsc;
  set maps.counties;
  where state in (37 45);
  /* FIPS codes for NC and SC */
run;
```

To import this spatial data, open the GIS Spatial Data Importing window with the following selections from the GIS Map window's menu bar:

- File ▶ Import

In the GIS Spatial Data Importing window, specify the following:

<table>
<thead>
<tr>
<th>Item</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import Type</td>
<td>SASGRAPH</td>
</tr>
<tr>
<td>SAS/GRAPH data set</td>
<td>WORK.NCSC</td>
</tr>
<tr>
<td>ID Vars</td>
<td>STATE and COUNTY</td>
</tr>
</tbody>
</table>

Map Entries

- Library: SASUSER
- Catalog: NCSC
- Name: NCSC
- Action: Create

Spatial Data Sets

- Library: SASUSER
- Name: NCSC
- Action: Create

After entering these values, select Import to begin importing the spatial data.

When you receive the message, “Import complete. Close this window to display the map.”, select CLOSE to close the GIS Spatial Data Importing window. The imported map is now displayed in the GIS Map window, as shown in Display 2.1 on page 16.
Changing the Default Characteristics of a Map

Once you have imported a new map or loaded a new SAS/GIS software spatial database from a commercial vendor, you may want to change some of the default characteristics of the map to suit your needs and preferences. Some of the characteristics you can change include

- the projection system used to display the map
- the scale mode and units
- the background color for the map area
- the layers that are initially displayed or hidden
- the level of detail for map features.

To learn about other ways in which you can customize the appearance of the map, see the chapter about customizing maps in SAS/GIS Software: Usage and Reference, Version 6.

Selecting a Map Projection

Projection is required to represent spherical features like the earth’s surface on a flat medium like a display screen or printed page. SAS/GIS software supports a wide
Preparing Spatial Data

Selecting a Map Projection

A variety of projection methods, but it assumes by default that the coordinate values in the newly imported spatial data are arbitrary cartesian (X/Y) values (except for TIGER and DYNAMAP which do assume latitude and longitude degrees). However, the coordinates in the MAPS.COUNTIES map data set are actually latitude and longitude values in radians. As a result, the initial Carolinas map in Display 2.1 on page 16 is elongated and reversed right-to-left.

To change the projection system used for the spatial data, you use the GIS: Projection Options window. Open the GIS: Projection Options window with the following selections from the GIS Map window’s menu bar:

Tools ➤ Map Properties ➤ Projections...

In the GIS: Projection Options window, Storage Projection System specifies the system used to interpret the stored spatial data, and Display Projection System specifies the system used to project the interpreted spatial data for display in the GIS Map window. Use the down-arrow controls to select Lat/Lon for both Storage Projection System and Display Projection System. Also in the storage system parameters, select W for Hemisphere and 1 for the Units Multiplier. Then select CLOSE to close the GIS: Projection Options window and apply the new projection specifications.

Note: This example uses the same projection system for the Storage Projection System and the Display Projection System.

After a brief delay while the spatial data are reloaded into the GIS Map window using the new projection systems, the projected version of the map is displayed as shown in Display 2.2 on page 17.

Display 2.2 Changing the Initial Map Projection
Selecting the Scale Mode and Units System

By default, the scale feedback for the newly imported map uses metric units and physical-unit/display-unit mode. To set the scale mode and units system of a new map, you use the GIS Map Options window. Open the GIS Map Options window with the following selections from the GIS Map window's menu bar:

Tools ➤ Map Properties ➤ Map Options

Select English for the units system to change the scale mode to mi/in (miles per inch), and then select CLOSE to close the GIS Map Options window and apply the change to the map feedback area as shown in Display 2.3 on page 18.

Display 2.3  Changing the Initial Unit System

56.170 miles/inch

Selecting a Background Color

By default, the map area is assigned a white background. To choose a different background color for the map, you use the GIS Map Styles and Colors window. Open the GIS Map Styles and Colors window with the following selections from the GIS Map window's menu bar:

Tools ➤ Map Properties ➤ Colors...

Use the down-arrow control for Background to display a list of the standard SAS colors and select Blue, and then select CLOSE to close the GIS Map Styles and Colors window and apply the new color choices as shown in Display 2.4 on page 19.
Choosing Which Layers Are Displayed

By default, only the first layer in the layer bar is displayed; other layers are hidden. To select which layers are displayed or hidden, click the mouse selection button on the corresponding layer bar buttons. Selecting a layer that is currently shown hides that layer, while selecting a layer that is currently hidden displays that layer.

In the example map, use the mouse selection button to hide the COUNTY layer and display the STATE layer as shown in Display 2.5 on page 20. When you are finished viewing the STATE layer, turn the COUNTY layer back on.
Changing the Level of Detail

In the spatial database, SAS/GIS software distinguishes between the coordinate points that are necessary to represent features minimally and those that provide extra detail. For example, the starting and ending intersections of a segment of a street are considered fundamental points, while additional points that represent the curves between the intersections are considered extra detail. By default, SAS/GIS software uses detail points for all layers if they are available. To turn off detail points for all features in the map, make the following selections from the GIS Map windows menu bar:

View ➤ Detail

The checkbox or check that appears next to the menu item when detail points are used disappears when detail is turned off.

With detail turned off, map features are drawn more coarsely but more quickly, since fewer lines are drawn. Display 2.6 on page 21 shows the resulting map. Turn detail back on to provide full detail to the map.
Linking the Attribute Data to the Spatial Data

Before you can use your spatial data as a basis for exploring your attribute data, you must link the attribute data to the spatial data. As explained in Chapter 1, “Introducing SAS/GIS Software,” on page 3, one way to use the attribute data after you have linked it to the spatial data is by creating a theme to control the appearance of features in the spatial data.

Position the pointer on the COUNTY layer name in the layer bar and press the mouse menu button to open the layer bar pop-up menu for the COUNTY layer, then select **Edit...** to open the GIS Layer window. In the definition for the COUNTY layer, select **Thematic**. The GIS Attribute Data Sets window opens for you to define the link to theme data set.

In the GIS Attribute Data Sets window, select **New** to define a new link. In the resulting Select a Member window, choose MAPS.USAAC. You must next specify the variables that are common to both the attribute and spatial data, since the common values of these variables are what provides the connection between the spatial data to the attribute data. The spatial database and the MAPS.USAAC data set share variables with compatible state and county codes, so first select STATE in both the **Data Set Vars** and **Composites** lists, then select COUNTY in both lists. Select **Save** to save the link definition to the **Links** list. Finally, select **Continue** to close the GIS Attribute Data Sets window.
After the GIS Attribute Data Sets window closes, the Var window automatically opens for you to select which variable in the attribute data provides the theme data for the layer. Choose CHANGE to have the counties colored according to the level of change in the county population, and then select OK to close the Var window. The counties in the spatial data are colored according to the demographic values in the attribute data set, as shown in Display 2.7 on page 22.

Display 2.7  Linking the Attribute Data as a Theme

![Display 2.7](image)

Note: The theme ranges in the COUNTY layer reflect the range of values in the MAPS.USAAC data set, which contains data for the entire United States. See the section on customizing theme ranges in SAS/GIS Software: Usage and Reference, Version 6 for details on how you can select different theme ranges that are more appropriate for the displayed counties.

Saving the Map Characteristics

Changes that you make while the map is displayed are not automatically stored in the spatial database. To record these modifications for use in future sessions, you must write them to the spatial database. You can save all changes by making the following selections from the GIS Map window's menu bar:

File ➤ Save ➤ All

As a safeguard, SAS/GIS software also offers you the option of saving changes when you attempt to close the map if any changes have not been saved.