Chapter Overview

In Chapter 3, you learned to produce listing, tabular, and counts reports. This chapter describes the SAS/ASSIST Report Engine, which is a more advanced, more powerful tool for producing reports. Using the Report Engine, you can create lists; tables; graphics, including bar charts, pie charts, and plots; and dynamic reports with drill-down features. You can easily change from one report style to another using the Report Engine.

Additional Information


Creating and Modifying a Simple List Report

The Report Engine allows you to generate reports quickly and gives you several ways to modify and customize different aspects of your report. This section shows you how to create a simple listing report and use the Report Engine’s customizing tools to make some modifications to the report.
Creating the Report

1. Follow this selection path:

   - Tasks ➤ Report Writing ➤ Design Report ➤ Report Engine...

   The Report Engine window appears.

   Display 15.1 Report Engine Window

2. If you have previously run a Report Engine report, the selections for that report are displayed automatically in the Report Engine window. If report selections exist in the Report Engine window, follow this selection path to clear all selections from the window:

   - File ➤ New

3. Ensure that the value in the Type field is SAS. If it is not, type SAS over the value in the Type field. Note that the Type field must be filled in before you select a table.

4. Use one of the following methods to select the SASUSER.HOUSES table:

   - Type SASUSER.HOUSES in the Data field and press ENTER.
   - Type a ? in the Data field, and then select the SASUSER.HOUSES table from the Select Table window. For more information on the Select Table window, see “Selecting a Table” on page 22.

   When the SASUSER.HOUSES table is loaded into the Report Engine window, SASUSER.HOUSES appears in the Data field. The table's columns are listed in the window.
5 Type **LIST** in the **Report** field in the Report Engine window, if it does not already appear there.

6 Follow this selection path to generate the report:

![Run Submit](image)

The report appears in the Report Output window.

**Display 15.3** Report Output Window

<table>
<thead>
<tr>
<th>Style of homes</th>
<th>Square footage</th>
<th>Number of bedrooms</th>
<th>Number of bathrooms</th>
<th>Street address</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONDO</td>
<td>1400</td>
<td>2</td>
<td>1.5</td>
<td>Market Street</td>
</tr>
<tr>
<td></td>
<td>1390</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>2105</td>
<td>4</td>
<td>2.5</td>
<td>Hampshire Avenue</td>
</tr>
<tr>
<td>RANCH</td>
<td>1860</td>
<td>2</td>
<td>2</td>
<td>Arcata Avenue</td>
</tr>
<tr>
<td></td>
<td>1500</td>
<td>3</td>
<td>3</td>
<td>Sheppard Avenue</td>
</tr>
<tr>
<td></td>
<td>1535</td>
<td>3</td>
<td>3</td>
<td>Kemble Avenue</td>
</tr>
<tr>
<td></td>
<td>720</td>
<td>1</td>
<td>1</td>
<td>State Highway</td>
</tr>
<tr>
<td>SPLIT</td>
<td>1190</td>
<td>1</td>
<td>1</td>
<td>Nicholson Drive</td>
</tr>
<tr>
<td></td>
<td>1615</td>
<td>4</td>
<td>3</td>
<td>Rand Street</td>
</tr>
<tr>
<td></td>
<td>1305</td>
<td>3</td>
<td>1.5</td>
<td>West Drive</td>
</tr>
<tr>
<td>TWO-STORY</td>
<td>1830</td>
<td>4</td>
<td>3</td>
<td>Graham Avenue</td>
</tr>
<tr>
<td></td>
<td>1040</td>
<td>2</td>
<td>1</td>
<td>Sanders Road</td>
</tr>
<tr>
<td></td>
<td>1240</td>
<td>2</td>
<td>1</td>
<td>Fairbanks Circle</td>
</tr>
</tbody>
</table>

If the report is wider or longer than one display, use the scroll bars, the **View** pull-down menu, or the FORWARD, BACKWARD, LEFT, and RIGHT function keys to look at the report.
Modifying the Report

The Report Engine offers you a number of ways to modify and customize your report. This section shows you some of them.

1. You can delete columns from the report output. For this example, position the cursor in the cmd field of the Number of bathrooms row, type D, and press ENTER. The Number of bathrooms row disappears from the Report Engine window, and the column will not appear in the report. The column does remain, however, in the HOUSES table.

2. You can modify the column headers. Position the cursor in the Column Header field of the Number of bedrooms row. Type Bedrooms over the existing column header text. You may need to delete or type blanks over the remaining column header text. Press ENTER; the column header will be renamed Bedrooms in the report.

3. You can rearrange the order in which the columns appear in the report. The values of No (for Number) determine where the columns appear, with 1 representing the left edge. Position the cursor in the No field of the Street address row. Type a 5, and then move the cursor to the No field of the Asking price row. Type a 4 and press ENTER. The Asking Price column will appear to the left of the Street Address column in the report.

   Note: If you wish to undo your modifications, follow this selection path:

   Edit ▶ Reset Columns

   This action restores the original columns, including their ordering and column headers, and it also restores any deleted columns.

Adding Titles to a Report Engine Report

Adding titles to a Report Engine report is slightly different from adding titles in the other SAS/ASSIST report-generating functions. Unlike the titles specified in other report-writing tasks, the titles you specify in the Report Engine are used in Report Engine reports only and do not carry over into other report writing tasks. Similarly, titles defined in other report writing tasks are not used in Report Engine reports.

1. To add titles to your Report Engine report, follow this selection path from the Report Engine window:

   Edit ▶ Titles

   The TITLES window appears.
2 Each numbered line in the Titles window represents a title line. A Report Engine report can have up to 10 title lines. For this example, type Houses for Sale in the Value field for title number 1, and then type By Style in the Value field for title number 2.

3 Return to the Report Engine window by following this selection path:
   File ▶ Close
   A prompt appears asking if you want to save your changes. Select Yes.

4 Titles appear flush left by default in Report Engine reports. To center the titles, follow this selection path:
   Edit ▶ Page Layout
   The Page Layout window appears.

Display 15.5 Page Layout Window
5 In the Center field, type
  YES
  and press ENTER.
6 Select OK. The Page Layout window disappears.

Running the Modified Report

1 Run the report with your titles by following this selection path:
   Run ➤ Submit

   Your report appears in the Report Output window, with the modifications and titles.

Display 15.6  Modified Report Output

2 To return to the Report Engine window, follow this selection path:
   File ➤ Close

Saving a Report to a SAS Catalog

To save a report for future use, follow these steps:

1 From the Report Engine window’s menu bar, follow this selection path:
   File ➤ Save As...

The Save As window appears.
2 Type a name for the report in the **Name** field. The name must be no longer than eight characters. For this example, type the name **LSTHOUSE**.

3 You may choose to type a description of the report in the **Description** field. The description must be no longer than 32 characters. For this example, type **Houses for Sale (Report Engine)**.

4 Select **OK** to save the report. If the report name exists, you are prompted to select **OK** again to write over the existing report, or you can type a new name for the report.

5 The Report Engine window reappears. If you modify the report further and wish to save it again, follow this selection path from the Report Engine window’s menu bar:

```
File ➤ Save
```

**Note** For a list of existing reports, type `?` in the **Name** field of the Save As window. You can type `S` (for Select) in the **Cmd** field to select a report from the resulting selection list. For a list of available catalogs, type `?` in the **Catalog** field. Select the catalog from the resulting selection list.

---

**Creating a Dynamic Report**

Dynamic reports enable you to set up a report and then drill down to view more details of the report.

---

**Creating the AIRLINE Sample Tables**

To appreciate the power of the dynamic report, you should use large and complex tables. This section shows you how to create the AIRLINE sample tables, a set of tables for a fictitious airline company called International Airways. The AIRLINE sample
tables are more complex than the SAS/ASSIST sample tables. There are tables with employee information as well as tables with information about flights, delays, boarding numbers, and so on. To create the AIRLINE sample tables, follow these steps:

1. If you are using the OS/390 or CMS operating environments, continue to step 2. Otherwise, create a library, directory, or folder, depending on your operating environment, where you want the AIRLINE sample tables to reside. You may name this library or directory anything you want, but we use the name `sampltab` in these examples. See the SAS companion for your operating environment, or contact the SAS Software Consultant at your site if you do not know how to perform this step.

   Note: The name `sampltab` that we use in these examples is the physical file or directory name. Do not confuse this name with the libname, which you will specify in a later step.

2. Go to the Program Editor window by using the PREVWIND function key or by clicking on the window, depending on your operating environment. From the Program Editor window, follow this selection path:

   File ➤ Open object...

   The Open window appears with a list of available libraries in the left pane.

3. Select the `+` symbol next to the Sashelp library. The contents of the Sashelp library appear in the left pane.

4. Scroll down in the left pane until you see the Qassist catalog. Select the Qassist catalog. A list of entries in the Qassist catalog appears in the right pane.

5. Scroll down in the right pane until you see the SampleSas source entry. Select the SampleSas source entry.

6. Select Open. The SampleSas program appears in the Program Editor window.

7. Scroll down in the Program Editor window (or use the DOWN function key) until you find the “Supply parameters” section, as shown in the following display.

   Display 15.8  SampleSAS Source Code

   

   00045  /*************** Supply parameters in this section ***************/  
   00046  00047  00048  00049  %let library = AIRLINE; /* ### Optionally change libref of sample  
   00050  table storage - the libref should  
   00051  be defined in a libname statement  
   00052  previously or at this point.  
   00053  Example: */  
   00054  00055  * libname &library "&sysjobid..sas.assist.sampltab";

   8. Find the line that reads

   * libname &library "&sysjobid..sas.assist.sampltab";

   You may need to scroll further down to find this line. This line is the LIBNAME statement that SAS software uses to assign a libref to a physical file or directory. For more information on librefs, see “SAS Data Libraries” on page 119.

   9. Remove the * by placing the cursor over it and pressing the SPACE BAR.
10 If you are using OS/390, continue to the next step. Otherwise, replace the information between the quotation marks (" ) with the name of the library or directory you created in step 1. (For CMS users, use the name in the following table.) Use the following table as a guide. Ensure that the name is enclosed in quotation marks and that a semicolon (;) is at the end of the line.

**Table 15.1** Examples of LIBNAME Statements

<table>
<thead>
<tr>
<th>Operating Environment</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>OS/390</td>
<td><code>libname &amp;library &quot;userid.assist.sampltab&quot;;</code></td>
</tr>
<tr>
<td>CMS</td>
<td><code>libname &amp;library &quot;SAMPLTAB FILE A&quot;;</code></td>
</tr>
<tr>
<td>OpenVMS</td>
<td><code>libname &amp;library &quot;DEVICE:[SAMPLTAB]&quot;;</code></td>
</tr>
<tr>
<td>UNIX</td>
<td><code>libname &amp;library &quot;/u/userid/assist/sampltab&quot;;</code></td>
</tr>
<tr>
<td>OS/2 or Windows</td>
<td><code>libname &amp;library &quot;C:\assist\sampltab&quot;;</code></td>
</tr>
</tbody>
</table>

11 To run the program, follow this selection path:

 ![Run ➤ Submit](image)

After the program finishes, statistics about the created tables appear in the Output window.

**Display 15.9** AIRLINE Sample Table Statistics

![Table Image](image)

Note: The Airline libref is assigned for the duration of your current SAS session only. The next time you invoke the SAS System and SAS/ASSIST software, you will need to assign the libref again by following the directions in “Using SAS/ASSIST Software to Assign a New Libref” on page 121. Alternatively, you can specify that the Airline libref be automatically defined, each time you invoke the
SAS System, by assigning the libref in the SAS Explorer window. See the online help for the SAS Explorer window for details.

12 Return to the Report Engine window by using the PREVWIND or NEXT function keys, or by clicking on the SAS/ASSIST window, depending on your operating environment.

---

Creating the Report

To create a dynamic report, you must add usages to the **Usage** column. Usages determine what a column represents and change the appearance of a report. For dynamic reports, usages determine the columns on which you can drill down.

1 Type `AIRLINE.MARCH` and then press ENTER in the Report Engine window's **Data** field.

2 For each column, enter the usage and column header indicated in the following table. Use the TAB key to move from field to field.

<table>
<thead>
<tr>
<th>Column No.</th>
<th>Usage</th>
<th>Column Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>GROUP</td>
<td>Flight</td>
</tr>
<tr>
<td>2</td>
<td>ACROSS</td>
<td>Date</td>
</tr>
<tr>
<td>3</td>
<td>GROUP</td>
<td>Time</td>
</tr>
<tr>
<td>4</td>
<td>SUM</td>
<td>Mail</td>
</tr>
<tr>
<td>5</td>
<td>SUM</td>
<td>Freight</td>
</tr>
<tr>
<td>6</td>
<td>SUM</td>
<td>Boarded</td>
</tr>
<tr>
<td>7</td>
<td>SUM</td>
<td>Transfer</td>
</tr>
<tr>
<td>8</td>
<td>SUM</td>
<td>Non-pay</td>
</tr>
<tr>
<td>9</td>
<td>SUM</td>
<td>Deplane</td>
</tr>
<tr>
<td>10</td>
<td>GROUP</td>
<td>Capacity</td>
</tr>
</tbody>
</table>

The usages for the columns create a drill-down report that shows the sum of the mail, freight, number of passengers boarded, number of passengers transferred, number of nonpaying passengers, and the number of disembarked passengers. Each of the columns can be shown by flight number, departure time, capacity, and date. The column headers have been shortened so that they fit in the Dynamic Report window buttons.

3 Type **DRILL** in the **Report** field, and then press ENTER.

4 Follow this selection path to run the report:

[Run] ➤ [Submit]

The Dynamic Report window appears, with eight buttons for columns defined with GROUP, ACROSS, BREAK, or PAGE usages.
5 Select **Flight** to obtain a list of all the flights along with the figures for mail, freight, boarded passengers, transferred passengers, nonpaying passengers, and deplaned passengers.

**Display 15.11**  Information by Flight Number

The figures for nonpaying passengers and deplaned passengers do not initially appear. If the report has more columns than can be displayed in the window, the scroll buttons (the small buttons below the eight analysis buttons) contain arrows to indicate the availability of additional columns. Select the right-arrow button to see columns to the right. Each time you select a scroll button, one new column appears.
6 Drill down on Flight 202 by selecting 202 in the table, and then selecting Date. The figures for Flight 202 for each date appear.

Display 15.12  Information by Date for Flight 202

![Image of SAS/ASSIST window showing information by date for Flight 202]

7 Drill down on 05MAR94 and select Capacity to display the capacity figures for Flight 202 on March 5, 1994.

Display 15.13  Capacity Information for Flight 202 on March 5, 1994

![Image of SAS/ASSIST window showing capacity information for Flight 202 on March 5, 1994]

8 To return to the Report Engine window, follow this selection path:

File ➤ Close
Exiting This Task

When you are ready to return to the WorkPlace menu or move on to another task, follow the directions in “Exiting a Task” on page 24.