Chapter Overview

This chapter shows you how to edit and browse your data. Editing your data enables you to make changes to your data. When you are browsing your data, you can only look at the data; you cannot change the data. You can edit or browse multiple rows of your data at one time in a tabular format, or each row separately, one row at a time. To browse your data, follow the instructions in this chapter, but choose Browse Data... instead of Edit Data....

Additional Information

For more information on editing and browsing data, refer to the online help for the FSEDIT and FSVIEW windows.
To edit or browse data, follow this selection path:

Tasks ➤ Data management ➤ Edit/Browse ➤ Edit Data...

The Edit Data window appears.

Note: For this example you will edit the data, but if you wanted only to browse the data, you would select **Browse Data...** as the last step of the selection path.

Display 7.1 Edit Data Window

Select **Tabular format**. The Edit Data in Tabular Format window appears.

Display 7.2 Edit Data in Tabular Format Window

If the active table is SASUSER.HOUSES, continue to the next step. Otherwise, select **Table**, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 22.
4 Select **Run** at the bottom of the Edit Data in Tabular Form window. The data from the SASUSER.HOUSES table appears in the FSVIEW window. Disregard any notes in the message area about a formula.

**Display 7.3** HOUSES Table Data

![Table Data](image)

When you edit data in a tabular format, multiple rows are shown in one window.  
5 To see the rest of the columns to the right of the window, use the scroll bars or the RIGHT and LEFT function keys. You can also use your FORWARD and BACKWARD function keys to move to the next and previous windows of rows if you have more rows than will fit in one window.

---

**Setting the Update Mode**

You can edit data in tabular format in one of two update modes: record-locking or member-locking. If you edit data in record-locking mode, you must first select a row before you can edit it. This method prevents you from accidentally editing the wrong row. If you edit data in member-locking mode, you can edit any row in the window without selecting it first. The default update mode is record-locking.

1 To set the update mode, select **Edit** from the menu bar, and then select **Update...** or **Set modification mode...**, depending on your operating environment. The **Update...** or **Set modification mode window** appears.
Display 7.4  Update Window

2  Select the update mode you want to use: RECORD (to edit one row at a time only after you have selected it) or MEMBER (to edit any row on the window). The Update window remains displayed.

For this example, select RECORD if it is not already selected, and then select OK. The FSVIEW window reappears.

---

Editing by Row

Use the following process to make changes to existing data. When record-locking is turned on, you must first select a row before you can edit it.

1  If you have not already done so, turn record-locking on by following the directions in the previous section.

2  To edit a row, select the row you want to edit. The row of data is highlighted to indicate that it is selected.

For this example, select row 15 (or the last row).

3  To edit the data, press TAB or use the right and left arrow keys to move the cursor to the data you want to change, and then type the new data over the old data. To edit another row, repeat these steps.

For this example, position the cursor on the CONDO style of row 15 (or the last row) and type SPLIT over CONDO (or over the existing style).

---

Editing by Member

Use this process to make changes to existing data. When member-locking is on, you can edit any row in the window without selecting it. To turn member-locking on, follow the directions in “Setting the Update Mode” on page 77, except select MEMBER in the Update window.
To edit a row, use the arrow keys to position the cursor on the data you want to change and type the new data over the old data.

---

**Adding Data**

Use this process when you want to add new information to the table. For example, you might want to add new houses for sale to the HOUSES table. Follow these same instructions to add data whether record-locking or member-locking is on:

1. To add data, follow this selection path:
   
   ![Edit] ➤ ![Autoadd]

   A NEW row appears at the bottom of the window.

**Display 7.5  Adding a New Row**

![Image of SAS: ASSIST window showing the HOUSES table]

When the AUTOADD feature is turned on, a new row is automatically displayed at the bottom of the table. This row is not added to the table until you enter values in it. After you enter values and press ENTER, the row is added to the table and another new row is displayed.

2. Type data in each column, and press TAB to move from column to column.

   Type the data where the cursor is placed within each column after you press TAB. After you type all the data for each column in the row, press ENTER. The numeric data align to the right of each column. The dollar sign and decimal are also added to the price after you press ENTER.

   After you type the number of baths, you can use the scroll bars or the RIGHT and LEFT function keys to display additional columns.

   For this example, type the data as follows:

<table>
<thead>
<tr>
<th>STYLE</th>
<th>CONDO</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQFEET</td>
<td>1420</td>
</tr>
<tr>
<td>BEDROOMS</td>
<td>3</td>
</tr>
</tbody>
</table>
When you have typed one row of data and pressed ENTER, another NEW row appears at the bottom of the window. This is a result of the AUTOADD feature.

When you have finished entering new rows, follow this selection path:

Edit ▶ Autoadd

The Autoadd feature is turned off.

**Duplicating Data**

If some rows are similar, you can duplicate a row and type in the data for the columns that are different. Follow the same instructions for duplicating rows whether record-locking or member-locking is on.

1. To duplicate a row, follow this selection path:

   Edit ▶ Duplicate...

   The Duplicate window appears.
Display 7.7  Duplicate Window

2 Type the number of copies you want to make and the number of the row you want to duplicate.

For this example, make two copies of row number 16 (or the last row), and then select **OK**. The duplicated rows appear at the bottom of the list of rows.

Display 7.8  Duplicated Rows

3 Edit the duplicated rows as necessary with the new data. For this example, select row number 18 and change the style to **SPLIT**.
Deleting by Row

If record-locking is on, you must first select a row before you can delete it. You can turn record-locking on by following the directions in “Setting the Update Mode” on page 77.

1. To delete a row, select the row you want to delete. The row is highlighted to indicate that it is selected. For this example, select row 18 (or the last row).
2. Follow this selection path:

   Edit ➤ Delete...

   The Delete... window appears.

3. Type the number of the row you want to delete (the row that is highlighted). For this example, type 18, and then select OK. The highlighted row is deleted and the FSVIEW window appears.
4. Also delete rows 16 and 17.

Deleting by Member

If member-locking is on, you can delete any row without selecting it. To turn member-locking on, follow the directions in “Setting the Update Mode” on page 77, except select MEMBER in the Update window.

1. To delete a row, follow this selection path:

   Edit ➤ Delete

   The Delete... window appears.

2. Type the row(s) you want to delete. Select OK. If you want to delete more than one row, type the row numbers separated by spaces. For example, type 1 3 5 to delete
rows 1, 3, and 5. If you want to delete a range of rows, type the beginning and ending row numbers separated by a hyphen. For example, type 12-15 to delete rows 12 through 15.

Select OK. The rows are deleted, and the FSVIEW window appears.

Creating a Subset of Your Data

If you only want to see part of the data (for example, if you only want to see all the houses for sale that are greater than 1500 square feet with three baths), you can create a subset of the data with a WHERE clause. The WHERE clause selects a subset of rows by comparing the values of the columns to the value you specify in the clause.

1. To create a subset of the data, follow this selection path:

   Search ➤ Where...

   The Where window appears.

   Display 7.10 Where Window

   Enter where clause:

   ![Image of Where Window]

2. To look at only the houses that have greater than 1500 square feet, type the clause sqfeet>1500, and then select OK. The HOUSES data in the window show only houses with more than 1500 square feet. The word Where appears at the top of the window to indicate that a WHERE clause is in effect.
To create a further subset of the data so that you see only the houses with more than 1500 square feet that have three bathrooms, follow this selection path:

Search ➤ Where also...

The Where also window appears. Type baths=3 to select only the houses with three bathrooms.

Select OK. The HOUSES data in the window show only houses with three bathrooms that are more than 1500 square feet.
The following is a list of some of the comparison operators that you can use in a WHERE clause (arithmetic, logical, and other operators are also available):

- **LT or <** less than
- **GT or >** greater than
- **EQ or =** equal to
- **LE or <=** less than or equal to
- **GE or >=** greater than or equal to
- **NE or <>** not equal to
- **IN** equal to one in a list

If you use character strings in the clauses, they must be enclosed in double or single quotes and must be in the correct case. For example, if you only want to see the ranch-style houses, you would type `style='RANCH'`. The word RANCH needs to be in all capital letters because all of the styles in the HOUSES table are in uppercase.

5 To undo the last WHERE clause (the restriction of three bathrooms in this example), follow this selection path:

Search ➤ Undo last where

The last WHERE clause that selected the houses with three bathrooms is removed, and all the houses with more than 1500 square feet appear.

Continue to select **Undo last where** to undo each previous WHERE clause.

### Saving

Periodically, you may want to save any changes and additions you have made to the data so that they are stored permanently. The autosave feature saves the changes for you after 25 row modifications. You can change the autosave feature so that it saves data after any number of row modifications you specify. You also can save data at any time.

- To save changes, follow this selection path:
  
  [File] ➤ [Save]

  Any additions or changes to the data are saved.

- To change the autosave feature, follow this selection path:
  
  [Edit] ➤ Autosave...

  The Autosave window appears. Type the number of row modifications after which you want to save your changes and additions. Select **OK**; the FSVIEW window reappears. Changes you make to the table are saved automatically after the number of row modifications you specified.

### Exiting the FSVIEW Window

When you have finished editing the data, exit as follows:

1 Follow this selection path:
When you edit data one row at a time, only one row is shown per window.

1. To edit data one row at a time, follow this selection path:

   File ▶ Close

   The Edit Data in Tabular Format window reappears.

2. Select Goback twice to return to the WorkPlace menu.

3. Select Single row. The Edit Data One Record at a Time window appears.

4. If the active table is SASUSER.HOUSES, continue to the next step. Otherwise, select Table, and then select the SASUSER.HOUSES table. For more information on selecting tables, see “Selecting a Table” on page 22.

5. Select Run. The first row of the HOUSES table appears.

   Display 7.13  First Row of HOUSES Table

   The row number is located in the top of the window. Each window presents one row in the HOUSES table. Each window is called a record or a row. Each field in the window represents a column.

Moving Around

To move to different rows, select View from the menu bar. From the View pull-down menu, you can:
select Next Observation to move forward to the next row ("observation" is another word for "row")

select Previous Observation to move backward to the previous row

select Observation Number... to move to a specific row. The Observation number window appears. Type the number of the row you want to display, and then select OK. The row you requested appears.

If you have too many columns to fit on one screen, each row has as many screens as necessary to display all the columns for the row. Use Next screen and Previous screen from the View pull-down menu to move from screen to screen within a row. The HOUSES table has only one screen per row.

You can also use the FORWARD, BACKWARD, RIGHT, and LEFT function keys to move from row to row and screen to screen.

---

**Editing Data**

To edit a row, position the cursor on the data you want to change, and type the new data over the old data.

For this example, display row 15 using the items from the View menu or the function keys. Change the style to CONDO.

---

**Adding Data**

Use this process when you want to add new information to the table. For example, you might want to add new houses for sale to the HOUSES table.

1. Follow this selection path:

```
Edit ➤ Add New Record
```

A blank row appears as the last row, and the word New appears at the top of the window.
Display 7.14 Adding a New Record

2 Type data in each field, and press TAB to move from field to field.
   Type the data where the cursor is placed within each field after you press TAB. After you have typed all the data for the row, press ENTER. The numeric data aligns to the right of each field. The dollar sign and decimal are also added to the price after you press ENTER.

   For this example, type the data as follows, and then press ENTER:
   STYLE SPLIT
   SQFEET 2200
   BEDROOMS 4
   BATHS 3
   STREET Maple Street
   PRICE 120000

3 When you have typed one row of data, you can continue adding rows using the instructions in steps 1 and 2.
   After you move to another row, the new row is assigned a row number.

Duplicating Data

If some rows are similar, you can duplicate a row and type in the data for the columns that are different.

1 To duplicate data, display the row you want to duplicate by using the items from the view menu or the function keys.
   For this example, display row number 1.

2 Follow this selection path:
   Edit ➤ Duplicate Record
The row displayed (row 1) is duplicated and added to the end of the rows in the table. The word New appears in the top of the window to indicate that this is a new (duplicated) row.

Display 7.15 Duplicated Record

3. Make any changes to the row as necessary. After you move to another row, the new row is assigned a row number.

For this example, change the style to CONDO.

Deleting Data

1. Display the row you want to delete by following this selection path:

   View ➤ Observation Number...

   For this example, display the last row by going to a row that is numbered higher than your last row, for example, 99.

2. Follow this selection path:

   Edit ➤ Delete Record

   The data in the row’s fields is deleted.

3. Follow this selection path to view the previous row:

   View ➤ Previous Observation

   Repeat step 2 to delete this row.
Canceling Changes

If you make any changes to a row, you can cancel the changes as long as you have not moved to another row, saved the row, or ended the editing session.

1. For this example, display row 3 by using the items on the View menu or the function keys.
2. Type xxxxx over the existing style.
3. Follow this selection path:
   ```plaintext
   Edit ➤ Cancel Current Changes
   ```

The style is restored to its previous value.

Creating a Subset of Your Data

If you want to see only a part of the data (for example, if you only want to see all the houses for sale that are greater than 1500 square feet with three baths), you can create a subset of the data with a WHERE clause. The WHERE clause selects a subset of rows by comparing the values of the columns to the value you specify in the clause.

1. To create a subset of the data, follow this selection path:
   ```plaintext
   Search ➤ Where...
   ```
   The Where window appears.
2. To look at only the houses that have greater than 1500 square feet, type the clause sqfeet>1500.
   
   Select ok. As you move from row to row, only houses with more than 1500 square feet appear. The word Where appears at the top of the window to indicate a WHERE clause is in effect.
3. To create a further subset of the data so that you see only the houses with more than 1500 square feet that have three bathrooms, follow this selection path:
   ```plaintext
   Search ➤ Where also...
   ```
   The Where Also window appears. Type baths=3 to select only the houses with three bathrooms.
4. Select ok. As you move from row to row, only houses with three bathrooms that are more than 1500 square feet appear.

The following is a list of some of the comparison operators that you can use in a WHERE clause (arithmetic, logical, and other operators are also available):

- LT or < less than
- GT or > greater than
- EQ or = equal to
- LE or <= less than or equal to
- GE or >= greater than or equal to
- NE or <> not equal to
- IN equal to one in a list

If you use character strings in the clauses, make sure they are enclosed in double or single quotes and are in the correct case. For example, if you wanted to
see only the ranch-style houses, you would type \texttt{style='RANCH'}. The word RANCH needs to be in all capital letters because all the styles in the HOUSES table are in uppercase.

5 To undo the last WHERE clause (the restriction of three bathrooms in this example), follow this selection path:

\begin{verbatim}  \end{verbatim}

The last WHERE clause that selected the houses with three bathrooms is removed, and all the houses with more than 1500 square feet appear. Continue to select \texttt{Undo last where} to undo each previous WHERE clause.

\section*{Saving}

Periodically, you may want to save any changes and additions you have made to the data so that they are stored permanently. The autosave feature saves the changes for you after 25 row modifications. You can change the autosave feature so that it saves data after any number of row modifications you specify. You can also save data at any time.

- To save changes, follow this selection path:

\begin{verbatim}  \end{verbatim}

Any additions or changes to the data are saved.

- To change the autosave feature, follow this selection path:

\begin{verbatim}  \end{verbatim}

The Autosave window appears. Type the number of row modifications after which you want to save your changes and additions. Select \texttt{OK}; the FSEDIT window reappears. Changes you make to the table are saved automatically after the number of row modifications you specified.

\section*{Exiting the FSEDIT Window}

When you have finished editing the data, exit by following this selection path:

\begin{verbatim}  \end{verbatim}

Select \texttt{Goback} twice to return to the WorkPlace menu.